What's the Best Hot Tub

Author Topic: Weak pump  (Read 346 times)

miatadude

  • Junior Member
  • *
  • Posts: 9
Weak pump
« on: April 07, 2021, 07:05:47 pm »
I posted this in the Marquis subforum, but also wanted to post it here.
We have a 2006 Marquis Epic? Can't remember the model right now but it is big with 2 pumps and has 2 lounges. About 3-4 months ago, the jets on one side started to get weak. I changed filters with very little difference. When troubleshooting, I removed the filter on that side and it functions as it should. Is my pump weak? I don't want to order one and replace it if you all think it could be something else.

Hot Tub Forum

Weak pump
« on: April 07, 2021, 07:05:47 pm »

Sam

  • Senior Member
  • ****
  • Posts: 1274
Re: Weak pump
« Reply #1 on: April 08, 2021, 01:57:54 pm »
Did you check the air controls?  Seems silly but we get this a lot.  The thing about spa pumps is that they don't ever "kinda work".  They either work or they don't.  Diminished pressure from the jets is typically either an obstruction in the lines or the air venturies aren't working properly.

CanadianSpaTech

  • Full Member
  • ***
  • Posts: 160
Re: Weak pump
« Reply #2 on: April 08, 2021, 04:02:38 pm »
I posted this in the Marquis subforum, but also wanted to post it here.
We have a 2006 Marquis Epic? Can't remember the model right now but it is big with 2 pumps and has 2 lounges. About 3-4 months ago, the jets on one side started to get weak. I changed filters with very little difference. When troubleshooting, I removed the filter on that side and it functions as it should. Is my pump weak? I don't want to order one and replace it if you all think it could be something else.

I think you kinda answered your own question. How old is the filter? When was the last time they were properly cleaned? When was the last time you soaked it in Ahh-Some filter cleaner? If you remove the filter and it works fine then it is most likely your filter.

miatadude

  • Junior Member
  • *
  • Posts: 9
Re: Weak pump
« Reply #3 on: April 08, 2021, 07:28:42 pm »
I ordered new filters today. We shall see if that is the culprit. Thanks for the responses.

Hot Tub Forum

Re: Weak pump
« Reply #3 on: April 08, 2021, 07:28:42 pm »

 

Home    Buying Guide    Featured Products    Forums    Reviews    About    Contact   
Copyright ©1998-2021, Whats The Best, Inc. All rights reserved. Site by Take 42