What's the Best Hot Tub

Author Topic: Double Moto Massage Help  (Read 118 times)

bdoer748

  • Junior Member
  • *
  • Posts: 10
Double Moto Massage Help
« on: February 06, 2020, 09:46:23 am »
Newby to the hot tub world.  Only issue im having on my 2012 Hot Springs Sovereign is my double moto massage is not going up and down.  Filters are brand new.  I tried adjusting the air valves and nothing.  Im assuming the air line or jets are just bad and will need replacing.  Best site to order these from.  As far as installation it looks really easy.  Just take off the covers covering the screws, unscrew the screws, pull out the air tube and twist off both moto massage jets.  When you reinstall make sure the circles or dots are in the 12/6 position and thats pretty much it.  I just balanced my ACE saltwater system so I dont feel like draining the tub.  Do I have to have the power off to switch out the moto jets?  Thanks! :)

Hot Tub Forum

Double Moto Massage Help
« on: February 06, 2020, 09:46:23 am »

bdoer748

  • Junior Member
  • *
  • Posts: 10
Re: Double Moto Massage Help
« Reply #1 on: February 07, 2020, 09:17:21 am »
Update......ended up replacing the moto jets yesterday.  Took the cover off.  Took the air hose off, unscrewed both moto jets and they were both toast.  Didn't drain any water.  I thought it would be difficult as you wouldn't be able to see as well with water in but it wasn't difficult at all.  Installed both jets and flipped on the breaker and we're back in business.  The wife and I fight over who get's the lounger seat with the dual moto jets in our Sovereign tub now lol.

ratchett

  • Junior Member
  • *
  • Posts: 59
Re: Double Moto Massage Help
« Reply #2 on: February 07, 2020, 10:22:11 am »
Woot! That's awesome to hear.  Did some research into these motomassager jets - it seems they can fail after 2-10 years of use depending on several factors including water care.  You must have done something right if you got nine years of life out of the first set!  I was hoping 2-years wasn't the normal haha

bdoer748

  • Junior Member
  • *
  • Posts: 10
Re: Double Moto Massage Help
« Reply #3 on: February 07, 2020, 11:28:48 am »
Thanks!  Now onto the next issue.  Why my LED on my waterfall isnt lighting up.  Trying to find some info on the web on how to replace that.  Noticed the light wasn't on when I was sitting in the tub and I had the water feature light on and a no go.

Hot Tub Forum

Re: Double Moto Massage Help
« Reply #3 on: February 07, 2020, 11:28:48 am »

 

Home    Buying Guide    Featured Products    Forums    Reviews    About    Contact   
Copyright ©1998-2020, Whats The Best, Inc. All rights reserved. Site by Take 42