What's the Best Hot Tub

Author Topic: Clicking Relay on an Old Bullfrog Hot Tub  (Read 189 times)

djemaine

  • Junior Member
  • *
  • Posts: 3
Clicking Relay on an Old Bullfrog Hot Tub
« on: October 29, 2019, 03:59:16 pm »
I have a 19 year old Bullfrog model 451 hot tub. The pump seal was leaking so I replaced the seal and motor bearings. After reinstalling the pump/motor and filling the tub, I powered it on. Pump/motor works fine, but one of the relays in the control box is clicking constantly. The clicking is very rhythmic, perfectly in time. Control box is a Balboa, model number DUM-BULF70-DCAH.

When I press a top-side control panel button, the clicking stops momentarily until the display changes, and then the clicking continues. When I unplug the top-side control panel wiring harness from the control box, the relay stops clicking. Clicking resumes when I plug the top-side control panel wiring harness back in.

One other thing to note: When the power is first turned on, the display shows "PR" to indicate that the pump is priming. The "PR" is soon replaced by "--F" indicating that the temp sensors are sensing the water temp. "--F" is supposed to go off after a minute, but it stays on much longer. I have not kept the tub powered on long enough to see the "--F" disappear, but it has been on in excess of 5 minutes.

Hot Tub Forum

Clicking Relay on an Old Bullfrog Hot Tub
« on: October 29, 2019, 03:59:16 pm »

castletonia

  • Full Member
  • ***
  • Posts: 659
Re: Clicking Relay on an Old Bullfrog Hot Tub
« Reply #1 on: October 29, 2019, 08:49:40 pm »
I would guess that you have a stuck button on the control panel since the clicking stops when it's unplugged. 

Tman122

  • Ultimate Member
  • *****
  • Posts: 4138
  • If it Ain't Broke
Re: Clicking Relay on an Old Bullfrog Hot Tub
« Reply #2 on: October 30, 2019, 08:52:27 am »
Is it heating?
Retired

djemaine

  • Junior Member
  • *
  • Posts: 3
Re: Clicking Relay on an Old Bullfrog Hot Tub
« Reply #3 on: October 31, 2019, 10:23:17 am »
Is it heating?

I'm not sure if it is heating. It never gets beyond the "--F" message before I power it down after 5 minutes or so

djemaine

  • Junior Member
  • *
  • Posts: 3
Re: Clicking Relay on an Old Bullfrog Hot Tub
« Reply #4 on: October 31, 2019, 10:29:55 am »
I would guess that you have a stuck button on the control panel since the clicking stops when it's unplugged.

I took the control panel apart and checked out the buttons. Nothing obviously wrong with any buttons. So I hooked just the circuit board back up and turned on the tub. It behaved normally - no relay clicking. I then pushed the buttons using a piece of wood, and they all seemed to function normally. So I let it run, but after 5 minutes or so the relay started clicking again. Based on this test, I think you are correct that the problem is caused by the control panel.

Hot Tub Forum

Re: Clicking Relay on an Old Bullfrog Hot Tub
« Reply #4 on: October 31, 2019, 10:29:55 am »

 

Home    Buying Guide    Featured Products    Forums    Reviews    About    Contact   
Copyright ©1998-2019, Whats The Best, Inc. All rights reserved. Site by Take 42