What's the Best Hot Tub

Author Topic: Arctic Spa power issue  (Read 515 times)

rshearerfam

  • Junior Member
  • *
  • Posts: 4
Arctic Spa power issue
« on: May 09, 2022, 06:25:18 pm »
Iím new to this group and hoping you all might be able to help us troubleshoot! We have a 2006 arctic spa, that we havenít had any issues with until last week. Opened the lid to get in and no power. The breaker had tripped, but now even resting the breaker we have no power. My husband thought he had isolated the issue to the transformer. We purchased a new transformer, and the hot tub turned on and staying running through the night. We checked it the next morning and no power again. We live somewhat remote and donít want to have to call a tech with a trip charge just to tell us itís dead or need expensive parts, hoping someone might have other ideas that we can try first. Thanks!!

Hot Tub Forum

Arctic Spa power issue
« on: May 09, 2022, 06:25:18 pm »

cranbiz

  • Full Member
  • ***
  • Posts: 194
Re: Arctic Spa power issue
« Reply #1 on: May 10, 2022, 09:08:20 am »
I suspect it's the heater but that's simply a SWAG.

Do you have a multimeter? If so, remove the power wires from the heater and then put the meter into ohms and check the element. It should read somewhere around 11-13 ohms.

Post up pictures of the spa pack, the wiring diagram and of the equipment area.


rshearerfam

  • Junior Member
  • *
  • Posts: 4
Re: Arctic Spa power issue
« Reply #2 on: May 10, 2022, 11:32:48 am »
Thanks! We do have a multimeter so we can test tonight. I will take some pictures and post as well!

rshearerfam

  • Junior Member
  • *
  • Posts: 4
Re: Arctic Spa power issue
« Reply #3 on: May 12, 2022, 08:19:30 pm »
So the test on the heater was fine. It was between 11 and 13 on the multimeter. All of the fuses are fine too. If we unplug the transformer and turn the power on, as soon as we plug the transformer back in it trips. Posting pics in a minute.

rshearerfam

  • Junior Member
  • *
  • Posts: 4
Re: Arctic Spa power issue
« Reply #4 on: May 12, 2022, 08:40:21 pm »
Apparently it won't let me post any pictures...

Hot Tub Forum

Re: Arctic Spa power issue
« Reply #4 on: May 12, 2022, 08:40:21 pm »

 

Home    Buying Guide    Featured Products    Forums    Reviews    About    Contact   
Copyright ©1998-2022, Whats The Best, Inc. All rights reserved. Site by Take 42