What's the Best Hot Tub

Author Topic: Master Spa Twilight 8.2 Tub Won't Heat Up  (Read 419 times)

voice903fm

  • Junior Member
  • *
  • Posts: 3
Master Spa Twilight 8.2 Tub Won't Heat Up
« on: May 26, 2019, 11:05:53 pm »
I have a Master Spa Twighlight 8.2 hot tub. It ran all summer and winter. Yesterday I turned off the power at the breaker, removed the old filters, drained and cleaned the tub. Then I refilled it and put in new filters. Turned power back on and tub went into Prime mode, then ask for the time to be reset.  All the pumps came on and ran perfect. The water temperature was 51 degrees so I set the desired temperature to 104 and covered it up at 2pm yesterday to let it heat up overnight. This morning 18 hours later it had only heated up 10 degrees to 61degree. I checked the settings and the tub is set to READY and the Temperature is set to HIGH. There is no error message on the display.  Throughout the day I checked and it stayed at 61 most of the day. I then cycled all the pumps on and then the temperature raised a degree. Once the pumps stopped the temperature stop rising. So all day I've been turning the pumps on to help it heat. It's now 8pm and the temperature is only at 71 degrees.   Seems like the heater to me but no indications on the display.  The tub is 2 years old. Never had an issue. What could be the problem?

Hot Tub Forum

Master Spa Twilight 8.2 Tub Won't Heat Up
« on: May 26, 2019, 11:05:53 pm »

Tman122

  • Ultimate Member
  • *****
  • Posts: 4084
  • If it Ain't Broke
Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #1 on: May 27, 2019, 07:32:23 am »
I have a Master Spa Twighlight 8.2 hot tub. It ran all summer and winter. Yesterday I turned off the power at the breaker, removed the old filters, drained and cleaned the tub. Then I refilled it and put in new filters. Turned power back on and tub went into Prime mode, then ask for the time to be reset.  All the pumps came on and ran perfect. The water temperature was 51 degrees so I set the desired temperature to 104 and covered it up at 2pm yesterday to let it heat up overnight. This morning 18 hours later it had only heated up 10 degrees to 61degree. I checked the settings and the tub is set to READY and the Temperature is set to HIGH. There is no error message on the display.  Throughout the day I checked and it stayed at 61 most of the day. I then cycled all the pumps on and then the temperature raised a degree. Once the pumps stopped the temperature stop rising. So all day I've been turning the pumps on to help it heat. It's now 8pm and the temperature is only at 71 degrees.   Seems like the heater to me but no indications on the display.  The tub is 2 years old. Never had an issue. What could be the problem?

It heats on low speed of pump 1. Does low speed of pump one pump water? Or is it air locked? Funny no code though.
Retired

voice903fm

  • Junior Member
  • *
  • Posts: 3
Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #2 on: May 27, 2019, 07:56:58 pm »
Pump 1 pumps water on low speed. No indication of any air locks. When it's in prime mode if there was air lock it wouldn't go to time setup screen.  It's 8pm today and it's only up to 81 degrees.   

Gomboman

  • Senior Member
  • ****
  • Posts: 1656
  • My Pride and Joy
Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #3 on: May 28, 2019, 10:43:00 pm »
That sounds very strange. Have you called your dealer? Maybe you bought from a spa show since it was a Master Spa? Good luck. Let us know how it turns out for you....
2005 Hot Spring Envoy still going strong. Million-Mile Club....

I want to get in the spa business so I can surf the internet and use Photoshop all day long.

Hottubguy

  • Senior Member
  • ****
  • Posts: 1786
Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #4 on: May 28, 2019, 10:48:55 pm »
Does it run continuously in low speed as if itís heating?  If so sounds like,a bad pc board

swilly1000

  • Full Member
  • ***
  • Posts: 163
Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #5 on: June 01, 2019, 12:24:58 am »
I remember a similar issue with my Twlight 8.25.  Can't recall specifics but I called my dealer and they told me how to fix it right away.  It was a setting in the control board.  Try your dealer.

Hot Tub Forum

Re: Master Spa Twilight 8.2 Tub Won't Heat Up
« Reply #5 on: June 01, 2019, 12:24:58 am »

 

Home    Buying Guide    Featured Products    Forums    Reviews    About    Contact   
Copyright ©1998-2019, Whats The Best, Inc. All rights reserved. Site by Take 42